韦德国际bv1946_www.bv1946com_韦德国际1946手机版
做最好的网站

导致整个工程跑不起来

日期:2020-04-29编辑作者:韦德国际bv1946计算机

最近因为项目需要,把CocoaPods更新到了最新版本1.0.1版本,更新完之后出现了一些莫名其妙的问题,导致整个工程跑不起来,报的都是第三方库丢失的错误,但是我查看工程的资源配置和Builder Phases —>Link Binary With Libraries,发现所有的库资源都没有少,但就是会报错,工程跑不起来。

后来经过研究,仔细分析了一下,推测的原因是:因为CocoaPods更新到1.0.1版本之后,在podfile里面需要加上target,用于指向目标工程,在这种情况下,如果执行pod update或pod install等更新操作的话,会重新生成对应于工程的libPods-XXX.a文件(注意:这里的XXX指代的是podfile里面的target或工程名),从而导致与原有的libPods.a文件冲突,这样就会导致工程编译出现奇怪的第三方库丢失错误。

图片 1

错误如图:

图片 2

解决办法:更新工程的配置,删掉原有的libPods.a文件。

如图:找到Build Settings—>Search Paths,将下图中的三项都加上 $(inherited)

图片 3

找到libPods.a文件,并将其删掉,重新运行工程。

图片 4

此时再运行工程,应该就可以跑起来了,是不是很开心?

本文由韦德国际bv1946手机版发布于韦德国际bv1946计算机,转载请注明出处:导致整个工程跑不起来

关键词: cocoapods 升级到 错误

SDK依赖的一些私有库会有频繁的更新

之前整理过一种打包静态库的方法:打包静态库(源码中包含其他静态库以及开源库)。不过这种方式的缺点很明显:...

详细>>

通知栏在target升级到26之后

buildToolsVersion "26.0.0" 或更高 "26.0.2"...compileSdkVersion 26targetSdkVersion= 26 通知栏 通知栏在target升级到26之后,如果不适配按...

详细>>

n多错误出现

终于将nachos安装成功 写文一篇已示庆贺,自己的安装过程: 使用Ubuntu 10.10安装 由于自带gcc4.4,版本太高,卸载之 ...

详细>>